Version in "./docker-compose.yml" is unsupported


#1

Hello everyone,

Trying to install my instance for the first time I get this error at the line docker-compose.yml

Here’s the error I get:

ERROR: Version in “./docker-compose.yml” is unsupported. You might be seeing this error because you’re using the wrong Compose file version. Either specify a version of “2” (or “2.0”) and place your service definitions under the services key, or omit the version key and place your service definitions at the root of the file to use version 1.

For more on the Compose file format versions, see Compose file version 3 reference | Docker Documentation

Please help me out ti fix it. Thank You!


#2

I think your docker-compose version (the executable program) is very old. Try a newer one


#3

a little help? I get it trough the command line apt-get install docker-compose and there’s no update available for it.

I’m running on Ubuntu 16.04 LTS, 64 bits

Thanks


#4

done. Thanks @Gargron


#5