Upgraded to 3.3.0, auth emails not sending

I just upgraded to 3.3.0 and I tried logging into one of my accounts on my instance and it’s trying to send an authentication email and I never receive it. I’m using the local SMTP server. “Regular” email is sent and received from the instance just fine. I looked in the logs, postfix, and I never see any message generated.

I do not know if other emails are being sent as this is a fresh upgrade.

I’m thinking no—because I just noticed as I typed this that sidekiq keeps restarting.

Jan  3 20:27:40 squid systemd[1]: Started mastodon-sidekiq.
Jan  3 20:27:46 squid bundle[11857]: 2021-01-03T20:27:46.995Z pid=11857 tid=156d WARN: /home/mastodon/live/vendor/bundle/ruby/2.7.0/gems/sidekiq-6.1.2/lib/sidekiq/cli.rb:63:in `run'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/live/vendor/bundle/ruby/2.7.0/gems/sidekiq-6.1.2/bin/sidekiq:31:in `<top (required)>'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/live/vendor/bundle/ruby/2.7.0/bin/sidekiq:23:in `load'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/live/vendor/bundle/ruby/2.7.0/bin/sidekiq:23:in `<top (required)>'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:63:in `load'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:63:in `kernel_load'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:28:in `run'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli.rb:494:in `exec'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in `invoke_command'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor.rb:392:in `dispatch'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli.rb:30:in `dispatch'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/base.rb:485:in `start'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/cli.rb:24:in `start'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/exe/bundle:49:in `block in <top (required)>'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/friendly_errors.rb:130:in `with_friendly_errors'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/exe/bundle:37:in `<top (required)>'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/bin/bundle:23:in `load'
Jan  3 20:27:46 squid bundle[11857]: /home/mastodon/.rbenv/versions/2.7.2/bin/bundle:23:in `<main>'
Jan  3 20:27:47 squid systemd[1]: mastodon-sidekiq.service: Main process exited, code=exited, status=1/FAILURE
Jan  3 20:27:47 squid systemd[1]: mastodon-sidekiq.service: Unit entered failed state.
Jan  3 20:27:47 squid systemd[1]: mastodon-sidekiq.service: Failed with result 'exit-code'.
Jan  3 20:27:47 squid systemd[1]: mastodon-sidekiq.service: Service hold-off time over, scheduling restart.
Jan  3 20:27:47 squid systemd[1]: Stopped mastodon-sidekiq.
Jan  3 20:27:47 squid systemd[1]: Started mastodon-sidekiq.

I see what looks like the emails maybe being queued up?

root@squid:/var/log# sudo systemctl status mastodon-*.service
mastodon-web.service - mastodon-web
Loaded: loaded (/etc/systemd/system/mastodon-web.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2021-01-03 19:37:17 UTC; 1h 6min ago
 Main PID: 1714 (bundle)
    Tasks: 31
Memory: 258.4M
CPU: 24.451s
CGroup: /system.slice/mastodon-web.service
��1714 puma 5.0.4 (tcp://127.0.0.1:3000) [live]
��2974 puma: cluster worker 0: 1714 [live]
��2975 puma: cluster worker 1: 1714 [live]

Jan 03 20:41:54 squid bundle[1714]: [ebce5358-bf37-4ac8-a39e-e30731a80dda] method=GET path=/users/hey/outbox format=json controller=ActivityPub::OutboxesController action=show status=200 duration=1154.34 view=2.91 db=3.37 key=http
Jan 03 20:41:55 squid bundle[1714]: [c93795af-6470-4651-9162-7bbf2a3da98b] method=GET path=/.well-known/webfinger format=json controller=WellKnown::WebfingerController action=show status=200 duration=9.65 view=5.18 db=0.54
Jan 03 20:41:55 squid bundle[1714]: [ec51d3bf-eddf-4bf8-8649-d3dc72d45836] method=GET path=/.well-known/webfinger format=json controller=WellKnown::WebfingerController action=show status=200 duration=5.11 view=1.33 db=0.50
Jan 03 20:41:56 squid bundle[1714]: [2e99b37e-3706-4ef6-be13-77068475d5a9] method=GET path=/users/hey format=*/* controller=AccountsController action=show status=200 duration=344.58 view=164.50 db=59.33
{snip other similar-looking processes}

Is 2.7.2 supposed to be a path under bundle/ruby? :

mastodon@squid:~/live/vendor/bundle/ruby/2.7.0/bin$ ./sidekiq -c 5 -q default -q mailers -q pull -q push
Traceback (most recent call last):
    2: from ./sidekiq:23:in `<main>'
    1: from /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/2.7.0/rubygems.rb:296:in `activate_bin_path' /home/mastodon/.rbenv/versions/2.7.2/lib/ruby/2.7.0/rubygems.rb:277:in `find_spec_for_exe': can't find gem sidekiq (>= 0.a) with executable sidekiq (Gem::GemNotFoundException)

Also affected, the instance isn’t federating.

I did notice another error about the version of redis. It says I’m running 3.0.6 and at least 4.0.0 is required.

The error in syslog

Jan  3 21:42:43 squid bundle[3406]: 2021-01-03T21:42:43.708Z pid=3406 tid=1c2y WARN: RuntimeError: You are connecting to Redis v3.0.6, Sidekiq requires Redis v4.0.0 or greater

and from the command line

mastodon@squid:~/live$ gem install redis
Successfully installed redis-4.2.5
Parsing documentation for redis-4.2.5
Done installing documentation for redis after 1 seconds
1 gem installed

Yet, it still gives me the error and continues to restart.

oof redis-server is 3.0.6. :frowning:

1 Like

redis-server was at 3.0.6. Upgraded to latest from source. Looks like OS needs upgrading soon, despite being LTS, it’s becoming outdated if I want to keep up with the latest mastosrc.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.