Unable to remote follow, or be followed remotely [solved]

If I try to follow an account on my new instance at https://mastodon.openpsycholgy.net/ from my mastodon.art account, I get an error:

503 Remote data could not be fetched

which gets displayed. This seems to be something that has to do with some configuration issue I’m having, as I am seeing errors, and things getting linked to https://mastodon.datsemultimedia.net/ which doesn’t exist.

I’m not sure where this is set, and it looks like at least one place things are set correctly. I’m not really sure what might be helpful with figuring this out.

It does seem to have a number of different symptoms, as avatars aren’t displaying correctly so somewhere I’ve got something setup incorrectly. I just can’t find it.

I found what the problem is. I never restarted redis, and it appears that by not doing that, it was storing some old setting that I had messed up some time ago. This is now solved.

1 Like

Does this also resolve the post you made here? Messages go out, but remote messages don't show up (federation issues)

Sadly, this seems to be only solved to the level that it’s not giving the same errors. The following isn’t happening. So many different things seem to go on.