Unable to login as admin

I am unable to login as an Admin on my instance or am doing it wrong, I am using the default login name of admin and the long string it gave me to use, but I am unable to login and the reset password email ability is not working.

how can both these be fixed

Keith

Hi Keith, did you get the Mastodon working on your nginx as described in another thread?

https://discourse.joinmastodon.org/t/mastodon-webpage-not-showing/2521/4

Yes site is up and running, just can’t login using admin and the password generated at the end of install

site is: topic-master.com

and emails are not be sent

Thank you so much for replying also

Ok, how did you configure your email server? Do you have any variables beginning with SMTP_ set in your environment file?

here is a snagit of the .en.production
image

The email server works for sending and receiving email from gmail.com
does that answer the question

can you check your email server logs please?

This is what I see, frankly not sure what it means

can you copy and paste as text please?

this means that an email has been delivered from kdmller45@gmail.com to admin@topic-master.com

This does not come from mastodon

I have tried to register, search for saper.info please and reply privately to me

I am unable to login as admin, is my first problem.

But do appreciate the help

For the admin problem I have only the generic advice:

  1. Try to check the mastodon logs
  2. Try to reset the password with Using the admin CLI - Mastodon documentation

I’m sorry have looked through the document and don’t see anything in the tootctl accounts area and what directory should I be in to perform the command i’m currently in /home/mastodon/live#

Sorry, I don’t know how to help you. You might need to fix your email to get the password reset working.

Thanks for trying, maybe someone will pick up where you left off

Thanks again
Keith

Without any information from the logs of your instance for example I don’t think there is any way.

I’m sorry what logs and where are they located, I’ll get them

I created a new admin account and found your enrollment and confirmed it and promoted you

1 Like

Thank you. It works now.

(I didn’t get any email in the process but that’s not necessary if you approve the account manually).

I did approve the account, still working on the port 587 look like the server is not showing it open, even with no fire wall enabled

which commands tell you that?