Supported PostgreSQL versions

This is not documented, so I was wondering what versions were supported. I know that 9.6 is, but are 10.x and 11.x too?

Right now Mastodon uses 10.6

10 and 11 work fine here.

1 Like

Mastodon supports Postgres 9.4 and higher, although 10 is very strongly recommended. There are no restrictions on the maximum postgres version.

1 Like

Thanks.

What about Redis?

I am not aware of any restrictions on the Redis version. If any, they would be imposed by the underlying libraries, but my guess is that nearly any redis version you can find will work.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.