[solved] Vagrant 1.9.8 on OSX (with 1.5.1 release)


#1

Hi,

I tried to run a Vagrant VM in order to test our own CSS but without any success:

$ vagrant ssh -c "cd /vagrant && foreman start"
08:36:40 web.1     | started with pid 31884
08:36:40 sidekiq.1 | started with pid 31885
08:36:40 stream.1  | started with pid 31887
08:36:40 webpack.1 | started with pid 31890
08:36:40 stream.1  | yarn run v0.27.5
08:36:41 webpack.1 | yarn run v0.27.5
08:36:41 stream.1  | $ node ./streaming/index.js
08:36:41 webpack.1 | error Command "webpack-dev-server" not found.
08:36:41 webpack.1 | info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
08:36:41 web.1     | [31886] Puma starting in cluster mode...
08:36:41 web.1     | [31886] * Version 3.9.1 (ruby 2.4.1-p111), codename: Private Caller
08:36:41 web.1     | [31886] * Min threads: 5, max threads: 5
08:36:41 web.1     | [31886] * Environment: development
08:36:41 web.1     | [31886] * Process workers: 2
08:36:41 web.1     | [31886] * Preloading application
08:36:42 webpack.1 | exited with code 1
08:36:42 system    | sending SIGTERM to all processes
08:36:42 web.1     | terminated by SIGTERM
08:36:42 sidekiq.1 | terminated by SIGTERM
08:36:42 stream.1  | terminated by SIGTERM
Connection to 127.0.0.1 closed.

I’m running it on OSX (latest version) with all software updated.

It seems that webpack-dev-server is missing, but why? I thought that everything needed to run the VM should be in the VagrantFile…

Have you any idea about this issue?


I also tried this, but again no success:

$ vagrant ssh -c "cd /vagrant && yarn install"
yarn install v0.27.5
[1/4] Resolving packages...
[2/4] Fetching packages...
warning fsevents@1.1.2: The platform "linux" is incompatible with this module.
info "fsevents@1.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.
warning store@1.3.20: The engine "browser" appears to be invalid.
[3/4] Linking dependencies...
warning "extract-text-webpack-plugin@2.1.2" has incorrect peer dependency "webpack@^2.2.0".
error An unexpected error occurred: "EACCES: permission denied, rmdir '/vagrant/node_modules/acorn-jsx/node_modules/.bin'".
info If you think this is a bug, please open a bug report with the information provided in "/vagrant/yarn-error.log".
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
Connection to 127.0.0.1 closed.

#2

Finally solved this issue doing this:

vagrant ssh
cd /vagrant
bundle install
chmod -R ugo+w node_modules
yarn install

And then to start Mastodon:

foreman start