[solved] Upgrading v1.4.3 to v1.4.6: [Webpacker] Compilation Failed

Hi,

I am in the process of upgrading v1.4.3 to v1.4.6, but when I recompile assets, this is what I got:

mastodon@host:~/live$ RAILS_ENV=production bundle exec rails assets:precompile
Webpacker is installed 🎉 🍰
Using /home/mastodon/live/config/webpacker.yml file for setting up webpack paths
[Webpacker] Compiling assets 🎉
[Webpacker] Compilation Failed
yarn run v0.24.5
$ "/home/mastodon/live/node_modules/.bin/webpack" --config /home/mastodon/live/config/webpack/production.js
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Killed
error Command failed with exit code 137.

Tried a few times, but still the same. I restarted mastodon services and my instance seems to work fine though I am not sure whether the assets were recompiled. But is this okay? Does any admin experience the same?

Thank you in advanced.

@self Hey, are you using a docker platform?

1 Like

@self If not make sure you’re updating dependencies first.

bundle install

and

yarn install
1 Like

Hi @danielolivas, I’m not using Docker and I did run ‘bundle install’ and ‘yarn install’ before recompiling the assets.

After I restarted Mastodon services several times, I recompile the assets again and it seems to successfully recompile again. :slight_smile: