Replacing of logo shows blank image

Hi,

Site URL : companies.social - Companies Social

I tried to replace the logo with my edited files and did exactly same as mentioned on this post : How to replace logos/ - #6 by vibhigupta

Steps I followed:

  1. Uploaded the edited files at /home/mastodon/live/app/javascript/images
sudo su - mastodon
cd live
RAILS_ENV=production bundle exec rails assets:precompile
systemctl restart mastodon-web.service

But, it doesn’t work and shows a blank image.

I would appreciate if anyone can help me on this?

Nand

When I look at your home page I get the following warning in the browsers console:

Content Security Policy: The page’s settings blocked the loading of a resource at inline (“style-src”).

Looks like some parts of your layout cannot load due to content security policy settings, that might be a reason

Any idea how should we resolve this issue ?

For testing purpose:
I tried update this : cybrespace/mastodon: The Cybre.Space fork of Mastodon -- https://github.com/tootsuite/mastodon - app/javascript/images/logo_full.svg at 0e0f18ce7c9796b25efa415436fe662f3f65bd25 - mastodon - Cybrespace Gitea

But still blank and no warning this time.

Nand