Not getting new messages unless i reload the page

Every time I post something or someone posts something I got to reload the page to see it

This is an issue with the streaming component of Mastodon. Check mastodon-streaming's logs and your reverse-proxy config.

all there is is a wall of error: SSL required

Do you have DB_SSLMODE or DATABASE_URL set in your .env.production?

adding DB_SSLMODE=true makes the site just always give 502

I see it was saying Error: self signed certificate in certificate chain

Is postgresql running on the same machine as the other processes? What happens if you set DB_SSLMODE=disable? Also you haven’t replied regarding DATABASE_URL.

Im using DO for my postgresql DB witch only works with SSL

Then I’d use a certificate that isn’t self-signed, if possible. If that’s not possible, one option would be to edit streaming/index.js in the block on line 128 with something like SSL | node-postgres

so the web part seems to be repeating this

Did you put DB_SSLMODE=true? Put prefer or leave it out.

Putting it as prefer worked but it still seems to not be getting new posts

Are there still errors in mastodon-streaming’s logs?

Still ERR! Error: self signed certificate in certificate chain

Then see my earlier message: Not getting new messages unless i reload the page - #9 by Claire

No matter what I put in it does not fix it

mastodon-web works just fine with the DB but mastodon-streaming does not I dont understand why it just does not work

Because it seems you use a self-signed certificate for the postgres server and node-postgres does not like that. Possible fixes would be to:

  1. use a valid certificate
  2. specify your custom certificate (ssl = { ca: … })
  3. do not validate the certificate (ssl = { rejectUnauthorized: false })

The first two would be the most secure.

…I take it you have never used a DO DB before so ill tell you something they mange it so that cant be done

so what spot do I put that because where I put it it did not work