NoMethodError: undefined method `lograge'

Currently trying to sort out the mimemagic mess and in the process other stuff has started to break.

I’m running Ruby 2.6.6 but I was attempting to upgrade to 2.7.2 when mimemagic ruined my day.

I’m currently back on 2.6.6, according to rbenv. .ruby-version states 2.6.6 too.

Mastodon version is v3.3.0.

I ran bundle update rails --minor and now when I run bundle exec rails assets:precompile I get this:

rails aborted!
NoMethodError: undefined method `lograge' for #<Rails::Application::Configuration:0x00007f9586c442d0>
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/railtie/configuration.rb:97:in `method_missing'
/home/mastodon/live/config/environments/production.rb:72:in `block in <top (required)>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/railtie.rb:216:in `instance_eval'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/railtie.rb:216:in `configure'
/home/mastodon/live/config/environments/production.rb:1:in `<top (required)>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `block in require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:608:in `block (2 levels) in <class:Engine>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:607:in `each'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:607:in `block in <class:Engine>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `instance_exec'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `run'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:61:in `block in run_initializers'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:50:in `each'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:50:in `tsort_each_child'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:60:in `run_initializers'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:361:in `initialize!'
/home/mastodon/live/config/environment.rb:5:in `<top (required)>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `block in require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:337:in `require_environment!'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:520:in `block in run_tasks_blocks'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.2/lib/sprockets/rails/task.rb:61:in `block (2 levels) in define'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/rake/rake_command.rb:23:in `block in perform'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/rake/rake_command.rb:20:in `perform'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command.rb:48:in `invoke'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands.rb:18:in `<top (required)>'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in `block in require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require_with_bootsnap_lfi'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.5.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in `require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
/home/mastodon/live/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
bin/rails:4:in `<main>'
Tasks: TOP => environment
(See full trace by running task with --trace)

Any help much appreciated.

Fixed by deleting the .bundle directory and running bundle install.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.