Nodejs upgrade to v8 possible?


#1

Hello,

for installing Mastodon I installed Nodejs v6 on my machine running Ubuntu 14.04. Now I want to set up a Peertube instance too. But Peertube requires Nodejs v8.

Can I just upgrade to Nodejs v8 or is there something I have to take care of for avoiding side effects on my Mastodon instance?

Thanks in advance
Mirco


#2

Make sure to rebuild binary nodejs modules (such as uws, node-sass). Old binaries with v6 will not work.