New instance not federating with other instances

Hi everyone,
I finally got my instance (introverts.social) up and running, however, I now have a new problem. When I try to follow someone from another instance, using my introverts.social account, I get the generic elephant-smashing-keyboard gif with the message “We’re sorry, but something went wrong on our end.”

How can I get more debugging info and find out what the actual error is? I tried restarting mastodon-streaming service but that didn’t help. Checking journalctl -u mastodon-streaming revealed nothing useful.

  • Also I tried creating an account redirect from my account on another server to my account on my new server, but it told me that the new account could not be found. Maybe this has a common cause with the first issue? Something about my instance is misconfigured so it’s not detectable from other instances, maybe?

Thanks,

There are three Mastodon services:

  • mastodon-web: the services handling HTTP requests (public pages, web interface, API requests and ActivityPub requests)
  • mastodon-sidekiq: the service running background jobs started by mastodon-web
  • mastodon-streaming: the service providing real-time updates to the web interface

If you get a “We’re sorry, but something went wrong on our end” message from your instance itself, the relevant logs are from mastodon-web, not mastodon-streaming.

I had a quick look at your instance, and my own instance can’t reach it due to a certificate issue: “certificate verify failed (unable to get local issuer certificate)”. This seems to be because you’re not including the full certificate chain: you are only including your certificate, but not the intermediary certificate(s), meaning that applications have to find and download those intermediary certificates, which browsers usually do, but not many applications such as Mastodon.

2 Likes

A-ha! Thanks so much, Claire, for bringing the certificate chain issue to my attention!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.