New installed instance , no upload in any kind


#1

hello ,

i used some guide to set up a new instance:

mastodon-guide/up-and-running.md at master · ummjackson/mastodon-guide · GitHub / found a wrong order in installation step
to get the 3rd secret

cybrespace-meta/s3.md at master · cybrespace/cybrespace-meta · GitHub / looks good. getting logs in AWS

but still have the question , why i get no upload to server , and why is no contend visabel? but connections are up


Instance Admins [Reply to Join]
#2

hello . i am running https://eifelcoworking.space since a few tries. But i always get no upload for any contend.
I used this mastodon-guide/up-and-running.md at master · ummjackson/mastodon-guide · GitHub for installation my VPS.
First i have to say :

needed to switch this 2 steps, to get the 3rd secret

docker-compose build <== this may take a while, go make yourself a cup of tea :coffee:

Now that the image is built, we’re going to generate 3 secret keys that are required for the configuration. Run this command 3 times and note down each of the keys generated, we’ll need them in a minute:

docker-compose run --rm web rake secret


but than there was in the “build” a fault about some ca.certificates …? do not solfed the problem and , sorry me, still have no idea how to.?

some ideas would be very welcome

thank you for your kindness


#3

Merged your two posts together. As the 2nd one did not belong in the other thread.


#4

What errors are you seeing? What problems are you having? I can’t understand from your messages what you’re trying to get help with.


#5

while installing mastodon:

docker-compose run --rm web rake secret

is running into

1st ->

±- uuid@3.1.0
±- v8-compile-cache@1.1.0
-- validate-npm-package-license@3.0.1 +-- spdx-correct@1.0.2 |– spdx-license-ids@1.2.2
`-- spdx-expression-parse@1.0.4

WARNING: ca-certificates.crt does not contain exactly one certificate or CRL: skipping
—> 0076c3f76149
Removing intermediate container 8be1094e3809

and 2nd-> fault message

yarn install v0.24.5
[1/4] Resolving packages…
[2/4] Fetching packages…
warning fsevents@1.1.2: The platform “linux” is incompatible with this module.
info “fsevents@1.1.2” is an optional dependency and failed compatibility check. Excluding it from installation.
warning store@1.3.20: The engine “browser” appears to be invalid.
[3/4] Linking dependencies…
warning “chai-enzyme@0.7.1” has incorrect peer dependency “chai@3.x”.

later the behavior of the instance is faulty.
there are no images uploadable . profiles are not customizable . all user profiles are at default image and also on other instances they are just in default image.


#6

none of those errors seem to be at all related to your later issues.

what errors are you seeing on the client side?


#7

what do you want exactly to know? I see no errors. There are this faults , that there is no realy working instance like i
told.
what do you mean “client side” ?

may be there are some rights not set for some path? but this was not documented in the guide.
some the files are not able to store? just a guess.


#8

@qatuno i run a non-docker instance, but maybe you should check out the official docker guide below, considering it’s updated frequently.


#9

as i understand this file i use is not needed to config. but i had a look inside to doublecheck. looks good as far.

i still think there is a conflict in my install user .

so we tried to run chown -R 991:991 public/system again with no effect.

still trying. some ideas !

But a question into the field : how many admin running mastodon virtual on a virtual machine?
I got an answer back from my VPS provider . Tell could be a problem … so tell me your opinion


#10

do you think it is a problem running docker and mastodon on a VPS? i got this answer by support team of VPS contributor


#11

I run mine on docker on digital ocean VPS with no issues. That chown command likely needs to be run within the docker container tho, not from the host. as thats where user/group 991 exists I think.

I accomplished similar on mine by, from the host, running sudo chmod -R 755 system/ from within the public directory


#12

DB_USER=your_username
DB_NAME=your_databasename
DB_PASS=your_password

this is a part of may installation i do not understand.

is there a default ?


#13

If using docker, you dont need to change these. Use as is in: mastodon/.env.production.sample at master · tootsuite/mastodon · GitHub

If you want your database persistant, just uncomment the noted lines in docker-compose.yml: mastodon/docker-compose.yml at master · tootsuite/mastodon · GitHub


#14

after i set database persistant, docker is not able toe rebuild the database ? . is this right ?


#15

If you rebuild it you lose everything in it. Thats kinda the point of keeping it persistent.


#16

1 i changed it into the “persistant” setup .

2 i added this How to Troubleshoot Nginx SSL Handshake failure? - Server Fault

3 but still get a 500Internal Server Error when upload some content.


#17

How much disk space do you have on the server?


#18

~ 300Gb 50% /boot

the VPS , still building ruby ( ruby-2.4.0)
and nokogiri -> gem install nokogiri

i think i was missmatched with the db image. because last tries i could not access it.
now i tried centos VPS / and the docker version of mastodon .

used the bitnami stack for redis and postgresqp / don’t ask why


#19

So it works now?

Also, may I ask if your preferred language is something other than English, so maybe we can find someone in our community who is fluent in that and can help you in that instead?


#20

i do not know. nginx is not yet above . centos7 is a little bit “crunchy”

rubygems-2.6.12]$ gem install bundler
ERROR: Error installing bundler:
invalid gem: package is corrupt, exception while verifying: undefined method `path2class’ for #Psych::ClassLoader:0x000000018cb918 (NoMethodError) in /home/mastodon/.gem/ruby/cache/bundler-1.15.1.gem