My first instance - became two instances


#1

This is my first attempt at setting up Mastodon. I am using docker and ran into some errors when first trying to set it up on Tuesday.

I resumed on Wednesday but apparently somehow created a new instance within the unfinished instance.

I didn’t realize there was a problem because everything was working properly until I tried to upload images today. I received the “We’re sorry, but something went wrong on our end” error graphic when I tried to upload an image for the thumbnail instance. I received the same error when trying to upload an image for my user profile (though the images showed on screen and only received an error when trying to upload).

Based on another message I read on here, I went to look at the permissions for PUBLIC to see if that might be the problem and was surprised to see that PUBLIC and the other directories all appear twice apparently. :astonished:

I am using a subdomain through DigitalOcean but the primary domain (games.ngo) is at another host. The subdomain is mastodon.games.ngo. The initial instance was within a directory called MASTODON and the (otherwise) working instance is in MASTODON > MASTODON.

Obviously my poorly-thought-out naming strategy has not helped.

Is it possible to fix this or should I just start over? The only problem I’ve had so far is uploading images. Everything else I’ve tested so far appears to work. Everything on this subdomain right now is related to Mastodon.

Thanks for any advice!

  • Drew

#2

What is your layout exactly? (A simple find . -type d would probably do). Do you have the code unpacked twice? Where does your web root point to exactly (a snippet from the webserver configuration would do).


#3

Thank you for responding. I decided it made more sense to start over.

It took me a while to sort out but I think everything works now: mastodon.games.ngo

Thanks again!