Mimemagic 0.3.5 no longer available

Hello,

While running bundle install I am getting the error that the bundle is locked to mimemagic 0.3.5.

After a bit of reading it appears that mimemagic 0.3.5 has been pulled and I need to update the bundle to 0.3.6.

I’m stuck at this point. Where do I go from here?

1 Like

I’d subscribe to All `mimemagic` versions prior to `0.3.6` have been yanked · Issue #15950 · tootsuite/mastodon · GitHub and Fix tootsuite/mastodon#15950 by lunaisnotaboy · Pull Request #15952 · tootsuite/mastodon · GitHub for updates.

If you feel lucky you can also try bundle lock --update

1 Like

Thank you. I’ve had a try, but it still refuses to build.

Can you post the messages you get?

1 Like

I noticed around the time mimemagic was yanked, my instance would not log me in and just keeps throwing the error page back at me. When I got back home I found the SSD was full, so I cleared that, restarted the servers, but the error still persisted.

I had a read the forums and figured it may well need an update. I jumped into the live folder and ran
[mastodon@server live]$ git fetch --tags

Then I stashed the changes and checked out to the (I assume) the latest stable branch with
[mastodon@server live] git checkout (git tag -l | grep -v ‘rc[0-9]*$’ | sort -V | tail -n 1)

I then ran
[mastodon@sony live]$ bundle install --deployment --without development test

I tried
[mastodon@sony live]$ bundle install

I tried
[mastodon@sony live]$ bundle lock --update

I’m stuck here.

Now it is too late, but one should always resist the urge to “update” until the original problem is fully solved. It might be very hard to find out what is the reason why the updated one does not work.

1 Like

Looking a the comments this will not be easy to fix…!

1 Like

Yes the issue is still the same before the attempted update. Mastodon still fires up even if there is an error opening the login screen.

SystemD reports no errors and all 3 services are running normally.

I think I will have to dig through the logs to see what’s happening.

Either way I was able to backup everything, so I can (if I can get it to install) reinstall it and restore the backup.

From the comments it does look like it’s possible, but it will take some head scratchings to figure it out.

What does it say? The elephant error? Do web server logs say anything?

1 Like

It’s the elephant error. I’ll have to have a look at the logs when I get back home.

Unfortunately, no Mastodon release is installable at this time. Hopefully a new one will be released soon, but until then there are basically two options for you:

  1. update to the development version of Mastodon (git checkout main && git pull origin main then bundle install, bundle exec rails assets:precompile, bundle exec rails db:migrate, restart the services and bin/tootctl cache clear)
  2. stay on 3.3.0, but manually update Rails to 5.2.5 with bundle update rails --minor (make sure to have the shared-mime-info system package installed first)
3 Likes

Nice one! I think I’ve done it with your excellent help, bundle install is now running. I’ve used your first solution. I’m getting the elephant error again. I’ll have another go later.

1 Like

Are these the only alternatives at this time? I’ve been reading online about updating mimemagic to 0.3.9 but I haven’t been able to get it to work. I keep getting the error that was posted in the original post.

Thank you.

Indeed, doing just bundle update mimemagic --minor might be easier. You might need to do gem install rake first.

After doing the above, I got the message "Unable to find a spec satisfying mimemagic (~> 0.3.0) in the set. Perhaps the lockfile is corrupted?
"

Oh. Maybe run bundle config deployment false before running bundle update mimemagic --minor and then run bundle config deployment true.

1 Like