Mastodon webpage not showing

I have a fresh install of Ubuntu 18.04 Server
fresh install of mastodon using Installing from source - Mastodon documentation
I didn’t see any errors during the install, but all I get when I goto my domain is the welcome to nginx screen

all three services started or atleast look like they did
systemctl daemon-reload
systemctl start mastodon-web mastodon-sidekiq mastodon-streaming
systemctl enable mastodon-*

what logs or such do you need to assist

when I try to perform systemctl enable mastodon-* I get the error failed to enable unit: Unit file mastodon-\x2a.service does not exist


Keith

Will systemctl enable mastodon-web mastodon-sidekiq mastodon-streaming work instead?

Can you show your nginx.conf file?

Apparently this got solved in the meantime.

Yes I did not know how to mark it solved or I would have and I am not authorized to delete, which is understandable, so other can follow the fix

P.S.

there is no firewall installed or enabled
I believe it is Mastodon v3.1.1

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.