Issue with blurhash preventing the mastodon-web service from starting

#1

I was in a hurry this morning and upgraded my Mastodon instance from 2.8.0 to 2.8.2 and didn’t think to look at the release notes for 2.8.1. Needless to say, stuff broke. I went back and followed the notes for 2.8.1 then the ones for 2.8.2 and the service mastodon-web still won’t start. It throws the following error and I’m not sure what to do with it.

~ $ systemctl status mastodon-web

● mastodon-web.service - mastodon-web
   Loaded: loaded (/etc/systemd/system/mastodon-web.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Fri 2019-05-10 09:52:07 EDT; 4h 57min ago
  Process: 2613 ExecStart=/home/mastodon/.rbenv/shims/bundle exec puma -C config/puma.rb (code=killed, signal=TERM)
 Main PID: 2613 (code=killed, signal=TERM)

May 10 09:51:58 nixnet.xyz bundle[2613]: [2f180180-6572-4661-8fb7-996dd444e9a4] method=GET path=/system/accounts/avatars/000/006/405/original/ac1b018c67a05f3d.jpeg format=jpeg controller=ApplicationController action=raise_not_found status=404 duration=19.75 view=0.00 db=11.80
May 10 09:52:00 nixnet.xyz bundle[2613]: [c3cc81ac-da43-411f-8569-a6beb84bce53] method=GET path=/api/v1/instance format=*/* controller=Api::V1::InstancesController action=show status=200 duration=5.67 view=0.47 db=0.86
May 10 09:52:00 nixnet.xyz bundle[2613]: [578b64ac-aab3-4e06-bae5-2d3e210c390e] method=GET path=/api/v1/timelines/home format=*/* controller=Api::V1::Timelines::HomeController action=show status=500 error='NoMethodError: undefined method `blurhash' for #<MediaAttachment:0x00007f00d7b27698>' duration=230.75 view=0.00 db=28.78
May 10 09:52:00 nixnet.xyz bundle[2613]: [578b64ac-aab3-4e06-bae5-2d3e210c390e
May 10 09:52:00 nixnet.xyz bundle[2613]: [578b64ac-aab3-4e06-bae5-2d3e210c390e] NoMethodError (undefined method `blurhash' for #<MediaAttachment:0x00007f00d7b27698>):
May 10 09:52:00 nixnet.xyz bundle[2613]: [578b64ac-aab3-4e06-bae5-2d3e210c390e]
May 10 09:52:00 nixnet.xyz bundle[2613]: [578b64ac-aab3-4e06-bae5-2d3e210c390e] app/controllers/api/v1/timelines/home_controller.rb:13:in `show'
May 10 09:52:07 nixnet.xyz systemd[1]: Stopping mastodon-web...
May 10 09:52:07 nixnet.xyz bundle[2613]: [2613] - Gracefully shutting down workers...
May 10 09:52:07 nixnet.xyz systemd[1]: Stopped mastodon-web.

Line 5 of the log looks to show the specific issue but, as I said, I’m not sure what to do with that information. I have completely removed ~/.rbenv and reinstalled ruby (version 2.6.1 as recommended) as well as removed ~/live/vendor and reinstalled all the dependencies following the installation guide. I’ve also run git reset HEAD --hard to remove my tweaks and set everything back to the way it should be. Following the upgrade guide after that accomplishes nothing either.

Mastodon is running with systemd on Debian Stable as its own user per the installation guide. I have made a few tweaks to increase toot, bio, and display name character limits but I don’t think those would have anything to do with this issue. To keep my tweaks across releases, I use git stash and git stash apply and manually resolve conflicts as needed by editing the files and searching for them.

Any help would be greatly appreciated!

#2

I’m not sure why this worked but it did. I check out version 2.8.1, ran git reset HEAD --hard, followed the upgrade guide, restarted, and stuff worked. So I checked out 2.8.2, followed the upgrade guide, restarted, and everything works. I just need to make a couple changes to bring back the 2k character toot limit and it’ll be back to normal :+1:

closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.