Images not showing/404 on new production instance

Hi Guys, I am totally new to Mastodon and a novice on Linux.

I successfully installed from source following the guide by Mastodon, and it went flawlessly, just having to make a few tweaks to suit our environment. Production.

It is running on Ubuntu 20.04 under Plesk.

Firing up Mastodon for the first time the login screen looks 100%. Images are loading and Favicon is visible.

After logging in, from that point no images. Looking deeper they are showing 404 errors.

I have tried searching for a solution but am having no joy. Any help will be much appreciated.

Below is the output from Inspector Console:

Had to modify links below to allow my to post in discourse

TSS: content-tss.js loaded: linktomydomain-

content-ads.js:1 INS: content-ads.js loaded: linktomydomain-

VM24:4 hosted page injected

inert.css:1 Failed to load resource: the server responded with a status of 404 ()

VM24:100 TSS: Counted history being replaced

VM24:105 TSS: caught history

VM24:62 TSS: Checking if repeated 500 times for interval 1000 against data: Object

screen_hello-1a8a513d829faf426fd2c6dc01ca79eb.svg:1 Failed to load resource: the server responded with a status of 404 ()

logo_transparent-9aedc3a098e790b61726b33fcd385cb4.svg:1 Failed to load resource: the server responded with a status of 404 ()

-sounds-boop.ogg:1 Failed to load resource: the server responded with a status of 404 ()

screen_federation-8bd8f7a8272cbcfa7caea060120acac0.svg:1 Failed to load resource: the server responded with a status of 404 ()

screen_interactions-4de710fdf37a699e5ca396d7a08e6bd7.svg:1 Failed to load resource: the server responded with a status of 404 ()

-sounds-boop.mp3:1 Failed to load resource: the server responded with a status of 404 ()

-android-chrome-192x192.png:1 Failed to load resource: the server responded with a status of 404 ()

mydomain.com-:1 Error while trying to use the following icon from the Manifest: linktomydomain-android-chrome-192x192.png (Download error or resource isn’t a valid image)

mydomain.com-:1 The resource linktomydomain-packs-js-features-home_timeline-8522825ab44b0b0aa6b2.chunk.js was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.

mydomain.com-:1 The resource linktomydomain-packs-js-features-compose-6b9513485a52383c4041.chunk.js was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.

mydomain.com-:1 The resource linktomydomain-packs-js-features-getting_started-ac6a1f26725fa47043fd.chunk.js was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.

mydomain.com-:1 The resource linktomydomain-packs-js-features-notifications-1189b337a1cec9759484.chunk.js was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.

inert.css:1 Failed to load resource: the server responded with a status of 404 ()

DevTools failed to load SourceMap: Could not load content for linktomydomain-packs-js-common-a34d4fc19bd4731b9983.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

DevTools failed to load SourceMap: Could not load content for linktomydomain-packs-js-locale_en-b5b2cd61feea2d246a92.chunk.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

DevTools failed to load SourceMap: Could not load content for linktomydomain-packs-js-application-cf9f90ef01d74d7d7b1e.chunk.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

DevTools failed to load SourceMap: Could not load content for linktomydomain-packs-css-common-3623162d.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

DevTools failed to load SourceMap: Could not load content for linktomydomain-packs-css-default-08e1136f.chunk.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

3mydomain.com-:1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.