Images and avatars don't federate to other instances


#1

Hello everyone.

I’m looking for help here.

I’ve had an increasing number of users telling me their media and avatars weren’t federating to other instances for an unknown reason. Avatars appear as the blank one on other instances, for example.

The instance is shelter.moe

I’m trying to diagnose the issue but it’s a really weird one and I don’t know where to look exactly. The public pages of my users are fine though, and images and avatars display correctly. However, it doesn’t seem to work correctly when trying to read posts and browse users from another instance.

Example with my account :

It displays fan from the public URL, however when trying to view it from say, mastodon.social :

Clicking ont he URL attached to the toot displays the picture in another tab correctly.

Where could I look for to try to diagnose the issue? Has anyone got this problem before?


Images don't federate *from* other instances
#2

Found the culprit.

I’m running apache, and enabling http/2 keeps mastodon from downloading images/avatars from your instance.

Disabling http/2 solved the issue :slight_smile:


#3

Does that mean you were requiring HTTP/2? Did other sites tried to reach you with HTTP/1.x and failed?


#4

Possibly. Having no idea of how the mastodon code works, I wouldn’t know if this is what happened.


#5

Ok, would be good to have some logs or details of the configuration change to figure out if this is something Mastodon can fix (unlikely) or Apache problem.