HTTP ERROR 500 on New Docker Install

I’ve run through the documenation and installed 3 times now using the install guide and then also looking at some other install guides available. This latest install I received no errors, everything went smooth but I’m getting a blank page. Interestingly you can put sub folders like pipes.social/settings and it knows to take you to the login page or the about page. But blank screen.

Notes: installed using digital ocean server with 3GB of ram.

website is https://pipes.social

I looked at the ingix error log and found this - I’m stumped as to a direction to go here.
2018/04/08 19:38:22 [error] 4437#4437: *7 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 47.221.151.215, server: pipes.social, request: "GET /favicon.ico HTTP/2.0", upstream: "http://127.0.0.1:3000/500.html", host: "pipes.social", referrer: "https://pipes.social/about"

And I found another issue that I never noticed when doing web rails precompile

Errno::EACCES: Permission denied @ dir_s_mkdir - /mastodon/public/assets/doorkeeper

The above issue was resolved by allowing permission.

How did you resolve this? I’m stuck at this particular issue and can’t get past it!

EDIT: Nevermind, fixed it!

For the sake of completeness, could you specify how you fixed this? Someone from the future who will come across this thread might be disappointed.

chmod on the directory/file if I remember correctly.

Ah! I’m an idiot that I didn’t read the instructions clearly, I was installing mastodon in the incorrect directory so just moving it to /root/mastodon and then following the instructions (the permissions one) fixed everything.

It was a silly mistake at my own part so there was nothing to be explained but FWIW, If someone in future is installing it, Please follow the instructions carefully.