HELP! Our Instance stopped working after upgrade to v2.9.3

We upgraded our instance from v2.8.3 to v2.9.3 following strictly indications at:


regarding release found at:

We are sure we did everything exactly as said at both pages.

We have found no errors and every thing went smooth during upgrade and during compiling.
Yet our Instance only shows error message " We’re sorry, but something went wrong on our end." at every page, except for /terms and /sign_up where we see their regular content.

PLEASE! How can we solve this?
Any help is fully welcome!

Have you tried to clear cache?

  • Non-Docker: RAILS_ENV=production bin/tootctl cache clear
  • Docker: docker-compose run --rm web bin/tootctl cache clear
1 Like

Have you followed the steps mentioned on how to upgrade to v2.9.3?
Did you add BIND=0.0.0.0 to your .env.production file if you did not specify a different binding for puma/node during install?

1 Like

Thanks kedamaDQ and ichii for your kindness and suggestions to help us.
Our instance is already working again.
Although it is not specified at the Upgrade instructions, we did a db:migrate at the end of the process and it got solved.
A great friend from inditoot suggested us to do this and it worked charmingly!
Thanks once again.

1 Like

After upgrading, you always have to check the release notes for that version - this lists additional steps that are release-specific.

E.g.: Release v2.9.0 · tootsuite/mastodon · GitHub

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.