Embed videos into your toots?


#1

Facebook and Twitter are great because you can upload videos and you can play them without having to leave their site. I understand why Mastodon doesn’t allow you to upload videos to other peoples servers. But what about an embeded video feature?

Something that when you post it, you can actually watch the video without having to leave. Has this been in the works at all? This would be a great feature for sites like Soundcloud as well. Or pratcially any embeded media.

Since a link looks ugly in the post. But an actually video with its thumbnail looks elegant, and the thumbnail alone can entice others to watch the video.


#2

Wrong start, try again :smirk:


#3

You can both uploads videos and embed other site’s videos in your posts.


#4

Thanks for your reply.

How do I embed a Youtube video per say.

When ever I post a link it just shows the hyperlink.

Do I just use HTML and it automatically it embeds it? I haven’t seen any other users do this.


#5

how ?
I found no explanation for how to do it, neither in the github repo nor in the discourse forum.
I tried this oembed method but it doesn’t seem to work any better than copying the embed link from youtube.


#6

Reply to both @ChameleonScales and @cumbiame

When you post a link, it is true that it only displays the link, in the timeline:
image

Then when you click on that toot, and open it on the side you get this:


#7

ah , I didn’t notice that.
It would be cool if it showed up all the time


#8

hi, i have the video thumbail in my pouet ( for example a youtube link ) but when i click on play, the thumbail become grey. nothing appear. any ideas?
From Chrome, a text says requests have been bloqued due to an extension ( same as private mode too )…

Thanx.


#9

what instance are you using? you should contact your local admin for support.


#10

i am, it’s on debian9, i have modified a lot of files, no results…


#11

Sorry, “I have modified a lot of files” is not something we can help with…


#12

I’m guessing this is a problem with your CSP header. You should make sure you’re using the CSP policy that comes with mastodon, and not a more restrictive policy.


#14

Thanks. i am going to search for nginx config policy.


#15

@Saper Hi, you could don’t respond if you whant to … say nothing ^^ Thanks for futures questions :slight_smile:

@Nightpool : Thanks a lot. You allright . the problem is solved by removing " default-src ‘none’; " in mastodon.conf ( from Nginx Sites-enabled ) in the line "add_header Content-Security-Policy " . Everything works now. Thank you sir.


#16

It seems to have changed. Now embedded videos display in the timeline too! :partying_face: