Disable explicit porn content


#1

Hi,
I’ve been traveling over some other toot servers, and it look like some of my users are following BDSM accounts. Is there a way to make it available only for the people who follows the accounts, but at the same time disable it for the rest of the people?
Even if I respect and can understand each ones preferences, I would prefer a place with no explicit porn on the timeline.

Thanks
C. Misson


#2

Most explicit porn should already be tagged as Sensitive Content, meaning that it’s blacked out completely on the timeline. Are you seeing something else?


#3

Might be us over at Humblr.social causing a bit of this.
Trying to make it so all our content is marked as adult. Any suggestions on how to do that?


#4

yes exactly @Humblr is comming from your server. I even rate BDSM but it kind a scares a bit new users when there is that much explicit content. Would be good if you can tag it or add the click to view option as default. Not sure how to do it, so far I only find the option of blocking the full domain or specific users, but I would like to avoid blocking a full domain as it’s a key part of the federation.
Welcome tumblers :wink:


#5

Make sure your users know to mark it as “sensitive content”. I believe there’s also a switter.at patch that enforces sensitivity during outbound federation, it should be somewhere in here: Commits · assemblyfour/switter · GitHub

i would suggest asking @j@switter.at for advice


#6

@j@switter.at hooked us up.
Should now not displayany of our content on other instances without warning.

Can’t search commits on GitHub?


#7

Nice one, it definetely worked on our instance


#8

We made the same change today.

On mastodon.social:

But on the instance the image isn’t marked as sensitive:


#9

That fix is only to show content on other instances from yours as sensative.


#10

Yep, this is correct