Can't follow accounts from specific instances


#1

Hello there. This is a weird one, I’ll try to be as brief as possible.

So I noticed this unusual behavior when following some public accounts :

  • I follow the person with the appropriate button, which changes color
  • I refresh the webpage, the “following” “people” icon turns to the hourglass one, as if the account was private and had to validate my follow, except it’s not
  • And I can’t see any update from the followed account

As I said in the title, this only happens with specific instances (catboy.cafe, mastodon.art for example). They are not blocked, and they did not block mine either. No problem of the sort with following people on newer instances for example. I tried with several accounts on my instance, none could successfully follow. It’s just so weird, I don’t even know where to start looking. Any suggestion is welcomed !


#2

We are having the same problem on mastodon.bida.im


#3

Oh hey, I solved this thing (for the most part).
For me, my issue was with ipv6 being not well configured.
You can test it with SSL Server Test (Powered by Qualys SSL Labs) if you want to check.

After that was solved, I still had troubles with one instance, and turns out that it was because we were blocked by them. It’s a bit sad it’s the same error message in this case, but oh well.

I hope this helps you troubleshoot your problem !