Cannot make myself admin - SOLVED

So I’ve got Mastodon running at on a Google Cloud VM running Ubuntu 16.04 with Docker.

The instance works, and I used this guide:

When I run the command:

docker-compose run --rm web rails mastodon:make_admin USERNAME=wtff

I get this error (output with --trace):

Starting mastodon_db_1    ... done
Starting mastodon_redis_1 ... done
rails aborted!
Don't know how to build task 'mastodon:make_admin' (see --tasks)
Did you mean?  mastodon:stats
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/task_manager.rb:59:in `[]'
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:159:in `invoke_task'
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:116:in `block (2 levels) in top_leve
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:116:in `each'
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:116:in `block in top_level'
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:125:in `run_with_threads'
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:110:in `top_level'
/mastodon/vendor/bundle/ruby/2.4.0/gems/railties-5.2.1/lib/rails/commands/rake/rake_command.rb:23:in `block in p
/mastodon/vendor/bundle/ruby/2.4.0/gems/rake-12.3.1/lib/rake/application.rb:186:in `standard_exception_handling'
/mastodon/vendor/bundle/ruby/2.4.0/gems/railties-5.2.1/lib/rails/commands/rake/rake_command.rb:20:in `perform'
/mastodon/vendor/bundle/ruby/2.4.0/gems/railties-5.2.1/lib/rails/command.rb:48:in `invoke'
/mastodon/vendor/bundle/ruby/2.4.0/gems/railties-5.2.1/lib/rails/commands.rb:18:in `<top (required)>'
1:in `require'
1:in `block in require_with_bootsnap_lfi'
in `register'
0:in `require_with_bootsnap_lfi'
9:in `require'
/mastodon/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in 
/mastodon/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_depe
/mastodon/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
/mastodon/bin/rails:4:in `<main>'

I’m not really finding any clues in that error message, so any advice would be greatly appreciated. Thank you to all the admins who deal with the headaches of running these instances for everyone to enjoy.


Did you use the latest tagged release (v2.5.0) in your docker-compose.yml file when you installed Mastodon? Or did you use the master branch?

I also had the same problem when I installed my test instance on Heroku, and it turns out it was because I used the master branch instead of a tagged release.

1 Like

Yes, I believe I just cloned the master branch with this command:

git clone

Then immediately started configuring .env.production and moving forward with the install.

I will try pulling the tagged release instead. Would that command look like this…?

git clone --branch v2.5.0 --single-branch

I see there’s also a stable-2.4 branch. Would that be a better choice for stability than the 2.5 tag?

Thank you for taking the time to reply. I’m going to start fresh with another VM and try this again. Will post results.

I’m not sure about the exact git command but I know this link worked for me on Heroku.

Dunno if a git clone would work on that exact link though.

Concerning that 2.4 branch, I would probably advise going with the 2.5.0 tagged branch as of now, it works pretty good and I haven’t had any issue with it so far.

1 Like

Looks like using a tagged version was the trick. It’s working now with v2.5. Thank you for the tip!

1 Like

Im running into this issue as well. Did you run the whole install over or is there a nice way to just rebuild?

I just completely started from scratch, spinning up a fresh VM of Ubuntu 18.04

I used this git command that seems to work:

git clone --branch v2.5.0 live

This guide is the one that worked (the official guide)

I also got another error, “Could not find nokogiri-1.8.4 in any of the sources
Run bundle install to install missing gems.”

In that case I just deleted the “live” folder and reinstalled Node JS and Ruby.