Avatar of New user are not loading

I just migrated to new server so after doing that everything is working perfectly I noticed new user and few local User avatar and header image are not loading.

I dont have any issue where the problem is and how to debug it.**

What could be the possible reason behind and how to know and fix it?

I looked at what the URL of the image was. I found that gave me some clues. Sometimes it (from what it looks like on my new instance) it is a bit of a matter of, “processing hasn’t completed yet” but that was maybe 2 minutes. Though most of the stuff has worked, or looked like chances are that it’s not working, in less than 2 minutes.

hmm actually its not few profile most of new user in federated timeline has this issue and it came after i moved to new host.
I dont have any idea how to debug this.


Did you copy over the public folder from your old host to new?

I did but its look like it didnt copied the complete folder

Can you tell me what to do now?

ok i make it work

Does the cmd create an Zip file first? it shows no space left.

I’d mostly check to see if the files that it’s looking for are showing up in the places it’s looking. I hope that makes sense.

I couldn’t find any other file on the vps and couldn’t understand why i need extra storage while running this cmd?

rsync -avz ~/live/public/system/ mastodon@example.com:~/live/public/system/

Its been sorted out by removing the swap file which gives enough storage

although its not showing 4.2 GB folder. I am a little confused how to know if i received all the files

I think that the -z will gzip the files before sending, and then reverse on the receiving end. It probably needs to have temporary storage on both machines, but it should be (unless I don’t understand) be just a bit more than the size of the gzipped largest file.

Yes it didnt work so I zipped the folder but i unable to find the zip. can you help locating the file?

Found it it is in root but not showing up in sftp

Its the host that creating a issue I even tried scp on other server it received but on scaleway on 99% no space left and scaleway has 35GB storage

Never Use Scaleway

I’m not really sure. Here is my understanding:

rsync [options] src [dest]

So your command:

rsync -avz ~/live/public/system/ mastodon@example.com:~/live/public/system/

Copies from the local ~/live/public/system/ directory to the ~mastodon/live/public/system/ directory on example.com

-a gives you “archive”, -v gives you “verbose” and -z gives you “compress”.

So that should leave you with the same file structure on example.com in the directory ~mastodon/live/public/system/ as you have on ~/live/public/system/ and you should get a list of each file as it transfers.

I hope that’s somewhat helpful.

1 Like

I Tried it with other Host eg digital ocean it works like charm but in case of scaleway its just doesn’t work i didnt take a nap since two days and i know nothing works on scaleway.

Its horror story

I created a zipped file and Use scp to transfer it on reaching 99% it says no space left and i tried same thing on digital ocean works like charm

Darn… I don’t know anything about scaleway. I assume some people like it. I was not happy with Digital Ocean, though it was worth trying. If only because they have data centres (well one I think) in my country.

If you’ve not been getting enough sleep, try to go get some, it’s worth catching up…

A good craftsmen does not blame the tool.

You have created multiple archives and probably are out of space because of it. So you don’t be able to make any more.

Use rsync without -a

I’m not sure this makes sense to me. If you’re suggesting that the -a means it creates a “new archive” this is not the case. It is the same as -rlptgoD which is:

  • -r - Recursive
  • -l - links
  • -p - preserve permissions
  • -t - preserve times
  • -g - preserve groups
  • -o - preserve owner
  • -D - Devices Specials

Without -r it would basically end up doing nothing. Some of those might not be needed, but you’re right, a good craftsman doesn’t blame the tool, but a good craftsman doesn’t tell a person how to use a tool in a wrong way as a criticism of the way they had done it which was correct.

The rsync command likely was not the problem. What might have been, honestly I have little to no idea. But bad advice is worse than no advice.

The error i am getting is “No Space left” It would be awesome if you have any solution to this.
I am able to send the file to digital ocean server but it failed on Scaleway


“df -h” in the command line of both the original server and the new server and copy the output to this forum.

Old Server

Filesystem      Size  Used Avail Use% Mounted on
udev            961M     0  961M   0% /dev
tmpfs           195M  3.1M  192M   2% /run
/dev/sda1        20G   14G  5.6G  72% /
tmpfs           973M     0  973M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           973M     0  973M   0% /sys/fs/cgroup
/dev/sda15      105M  3.6M  101M   4% /boot/efi

New Server

Filesystem      Size  Used Avail Use% Mounted on
udev            2.0G     0  2.0G   0% /dev
tmpfs           395M   11M  384M   3% /run
/dev/vda1        46G  8.7G   35G  20% /
tmpfs           2.0G   12K  2.0G   1% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           2.0G     0  2.0G   0% /sys/fs/cgroup
/dev/vda15       99M   512   99M   1% /boot/efi
tmpfs           395M     0  395M   0% /run/user/0