Account migration fails - account alias not found?

TL;DR:
I’m unable to migrate old accounts to a new instance’s admin account because the account aliases can’t seem to be seen outside the instance. Migrating between old accounts in other instances works fine. Migrating a new account from outside the instance into a new (non-admin) account on the new instance works fine.

Error message:
Handle of the new account is not back-referencing this account

The accounts (letters are for reference use in text below):
[A] @konc@photog.social (old account)
[B] @konc@writing.exchange (old account)
[C] @konc@mastodon.justafellow.com (new account I want to keep)

Since initially posting, I’ve also created these accounts:
[D] @vjeko@mastodon.social
[E] @vjeko@mastodon.justafellow.com

I have created account aliases for accounts [A] and [B] on the third account [C]

image

When I then try to run the migration (from an old account) it fails. I get the same error from both old accounts.

Handle of the new account is not back-referencing this account

Then, to check if the issue I have is with the feature or my instance, I attempted to migrate account A to account B using the same procedure and it worked just fine, leading me to think that something’s not quite set correctly in my new instance.

I then got the suggestion to create two new accounts, one on another instance instance (account [D]) and one on my instance (account [E]), and I was able to instantly migrate [D] -> [E], and even [E] -> [C].

I’ve also tried to create an account alias from [B] to [C], even though it should’t be needed (and I’ve only ever needed one-way aliases for the migrations that have worked).

I’m hoping that someone else has insights that can help me figure this out.

Can you have a look at the issue 12216? There needs to be a two-way alias and there is also some caching involved for 2 days.

I’m not quite sure what you mean with two-way alias.

To be on the safe side I’ve tried to create an account alias from @konc@writing.exchange (old account) to @konc@mastodon.justafellow.com (new account I want to keep) as well, despite there being no indication that I’d have to do it that way. That also didn’t solve my issue.

The very same procedure I’ve used when trying to migrate old accounts to my new instance’s admin account work just fine between other accounts, even a newly created account on the same new instance and no two way aliases were needed. For some reason all migration attempts to the admin account fail.

I guess I should update the initial post to include what else I’ve done since posting.

1 Like

Thanks - I have never did the account migration, just looked up a potentially related issue. It seems that account aliases may be cached so the effect of the change may not be immediate.

Decided to try the migration thing again, and today it worked without any issues the first time around.

Must have been a caching issue or something, I’m still not sure what exactly.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.