Able to get SMTP configuration mail, unable to receive register mail

Hello, I have just set up my instance and it seems well. I can log in as admin and send an invite link, but after I register a new account, I can’t receive the mail.


this is what I received when i set up the configuration.

but i can’t register a new account. I have tried several times and wait for hours…

[sorry i edited it as i am a new user and i can’t post more than 3 links in the thread]
SMTP_SERVER=smtp[dot]yandex[dot]ru
SMTP_PORT=587
SMTP_LOGIN=notifications@mysite[dot]com
SMTP_PASSWORD=mypasswd
SMTP_AUTH_METHOD=plain
SMTP_OPENSSL_VERIFY_MODE=none
SMTP_FROM_ADDRESS=‘Mastodon <notifications@mysite[dot]com>’

and this is my .env.production. My instance runs on Ubuntu 18.04. I use yandex as the SMTP server.
I have also checked the spam but find nothing.

and this is my invite link: Sign up - aphasiagoverned
however, it can’t register successfully

Thanks for any help.

Updated:
I have solved this problem by restarting my instance. Using the command listed in Upgrading to a new release - Mastodon documentation

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.